Back to overview
Resolved

Roblox login on Orbit Site unavailable

Jul 20, 2026 at 12:39pm UTC
Affected services
orbit.m12gyt.lol

Resolved
Aug 21, 2026 at 10:21pm UTC

We added a trailing slash to the url of the site, so it failed

Oopsies :3

Updated
Jul 28, 2026 at 3:23pm UTC

We may have found the cause. Please bare with us.

Created
Jul 20, 2026 at 12:39pm UTC

We are currently investigating Roblox logins on the Orbit site. For a longer time the redirect URL is invalid.