Back to overview
Resolved

Orbit site currently down

Jul 19, 2026 at 10:28am UTC
Affected services
orbit.m12gyt.lol

Resolved
Jul 19, 2026 at 10:44am UTC

The instance has been updated and is now back up.

Operations are now back to usual.

Updated
Jul 19, 2026 at 10:33am UTC

We are updating the instance and restarting it.

Should be resolved in 10-20 minutes

Created
Jul 19, 2026 at 10:28am UTC

The orbit site is currently down. We are investigating the matter at this time.

The site is active but not loading.