Back to overview
Resolved
Pterodactyl Panel outage
Jul 11, 2026 at 5:38pm UTC
Affected services
pterodactyl.m12gyt.lol
Resolved
Jul 11, 2026 at 6:33pm UTC
We have fixed the issue and have implemented changes to speed up the startup of the pterodactyl for quicker resolution.
Affected services
Created
Jul 11, 2026 at 5:38pm UTC
The Internal hosting panel is down and will be unavailable.
Affected services